Back to overview
Maintenance

Platform Mainenance

May 14, 2026 at 3:00pm UTC  –  May 14, 2026 at 6:00pm UTC
Affected services
Main Application
Main API

Resolved
May 14, 2026 at 6:00pm UTC

Maintenance ended

Created
May 14, 2026 at 3:00pm UTC

Will be performing infrastructure upgrades this afternoon. We do not expect any significant impact on services, but users might experience some latency issues.